K3 Dataswitch - Email Service – Incident details

All systems operational


For the latest news on whats been released into our Products, please visit the Release Notes.

Email Service

Resolved
Partial outage
Started almost 2 years agoLasted about 8 hours

Affected

Power Assets

Partial outage from 2:18 PM to 10:23 PM

Email

Partial outage from 2:18 PM to 10:23 PM

Updates
  • Resolved
    Resolved

    We have resolved the issue.

  • Identified
    Identified

    We have identified the issue and engineers are actively working on a fix.

  • Investigating
    Investigating

    We are currently investigating an issue with Emails not being sent out from dataswitch platform.